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From SONAR to REAPER
Introduction and Preamble
This booklet has been produced as an aid to experienced users of SONAR who are trying out REAPER, or who have already decided either to make the switch or to add REAPER to
their software collection.
It is an introductory guide and no more. Each chapter presents a table devoted to one main aspect of using a DAW. Within each table you will find a number of key tasks
identified, together with a summary of how that task is approached in SONAR and how the same (or most closely equivalent) task is approached in REAPER. Where I have been
unable to identify a Sonar feature equivalent to a particular REAPER feature I have written “SONAR does not appear to support this.” Please do let me know if I am wrong here.
Just PM nicholas on the REAPER forum. The versions used are SONAR Professional (October 2017) and REAPER 5.60 with SWS Extensions 2.9.7. The SWS Extensions can be
downloaded from: http://www.sws-extension.org
The layout has been designed so as to make it easy for you to print any page you wish as a summary information card. You will find more explanations in the REAPER columns of
the tables than the SONAR ones. That is simply because I have assumed that as an experienced SONAR user you are already reasonably familiar with how SONAR handles the
various tasks. The last page consists of a summary table of the default keyboard shortcuts (where they exist) for REAPER’s main menu commands. This information is provided as
a reference point only, not to teach you how to use SONAR.
This document is far from being 100% comprehensive, nor is it intended to be, nor (probably) could it ever be. I have had to take some fairly arbitrary decisions about how this
documentation approaches these at times, including what to include and what to miss out. I didn't want to end up with another 400+ page manual! Its aim is to help you adjust
to REAPER's way of working, not to teach you everything you could, possibly want to know about REAPER. Be prepared in most cases to consult the REAPER User Guide, the SWS
Extension Guide and Kenny’s videos for more information on most topics.
Finally, to state the obvious, SONAR isn't REAPER and REAPER isn't SONAR. I've considered questions like whether it would be a good idea to create pseudo-SONAR menus that
you can use with REAPER, or pseudo-SONAR keymaps. After consulting with other ex-SONAR users I have decided against doing this. Apart from the extraordinary amount of
time this would take, there are more philosophical reasons. These are:
● The two programs operate in many cases quite differently and according to different design paradigms. Trying to “Sonarize” the REAPER menu would be at best a fudge.
Some commands would need to be included which are not strictly equivalent, others would be dropped off the menu all together.
● Changing REAPER's keyboard shortcuts to more closely align with SONAR's key bindings would mean re-allocating keys currently assigned some other function (and often
an important function) in REAPER. In some of these cases, SONAR has no equivalent command.
● In the end, the only way you will ever successfully be able to learn and use REAPER is … to use it as REAPER, not as a sort of quasi-SONAR (or anything else). This might
make the learning curve a little steeper at first, but in the longer term this should save you time and deliver you benefits.
If you find any significant errors or omissions, or would like to suggest improvements, please PM nicholas on the REAPER forum.
Finally, here's one more point to consider …
One criticism sometimes leveled at REAPER is that it is “complicated” or “difficult” to use because of its many hundreds of extra actions, many of which lie hidden below the
surface. In my opinion, nothing could be further from the truth. REAPER's standard interface contains all of the commands, functions and features needed to run it as a standard
DAW. For the most part, the extra actions are there to help you if you want to tailor the program to work more precisely in line with your own needs (for example, to improve
your productivity and workflow). You don't need to do this if you don't wish to! Enjoy!
– Geoffrey Francis, August 2010, updated December 2017
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From SONAR to REAPER
1. Fundamental Design Differences
On the surface, SONAR and REAPER look quite similar. They are both Digital Audio Workstations. Both allow you to record audio and MIDI items. Both provide you with facilities for editing
these items. Both offer a number of useful features (such as VST plug-ins and automation envelopes) to help you to bring your projects to a final mix. And so on ….
That's on the surface. Once you start looking below the surface you will discover four very important things:
● There are some tasks common to both SONAR and REAPER which are accomplished in a similar fashion in both programs. However, these tasks are relatively few in number and
relatively basic. They include such standard Windows activities as saving files, opening files, closing files, deleting clips and items.
● There are some features which are common to both SONAR and REAPER but which are accomplished by different means in the two programs. For example, the default methods of
zooming in and out of, and navigating thru, a project are significantly different in both programs.
● There are some features which though broadly comparable in SONAR and REAPER vary significantly in their implementation and their functionality. For example, SONAR's Audio
Snap and REAPER's stretch markers and transient guides both exist to serve similar purposes. Both, however, work differently from each other. Likewise, both programs make
automation available to you, thru the use of envelopes and (in the case of REAPER) parameter modulation, a feature that is not supported in SONAR. Most people who have used
both programs for automation would say that REAPER is superior in this regard.
● Both programs possess features that the other simply does not have.
You will find the transition from SONAR to REAPER easier if from the outset you develop at least a general sense of the differences in the design paradigms of the two different programs.
The table below aims to explain some of the most important differences. It comes with the usual disclaimer that its statements are generalizations and perhaps at times over-simplifications.
Nevertheless, it should help to get you thinking along the right track.

SONAR
●

Audio and MIDI items are called “clips”. In this document I'll use the REAPER term
“media items” when referring to SONAR clips..

●

Makes extensive use of Main Level Menus.

●

Includes a large number general and specialist of toolbars, makes extensive use of
tools. User can create custom toolbars.

●

Makes some use of right-click context menus.

●

REAPER
●

Audio and MIDI clips are called “media items”.

●

Makes extensive use of Main Level Menus. These can be customized to meet the
user’s own requirements.

●

Default toolbar is minimal. By default, REAPER makes little use of tools, but users
can customize the main toolbar. You can also create your own tools and your own
custom toolbars.

Limited keybinding capability.

●

Makes extensive use of right-click context menus. Most of these can be customized.

●

No extra actions other than what appears on menus. No user macros.

●

Extensive keybinding capability.

●

Some scripting capability thru CAL.

●

●

Limited ability to customize program settings and options.

Literally hundreds of extra actions that can be combined with each other and with
REAPER commands into user-defined macros.

●

Supports scripting using LUA, EEL (if you insist) Python.

●

Very many aspects of program behavior can be customized.

Some of these issues will be discussed further in the section Customization.
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2. Setting Up and Getting Started
Section Overview
Any DAW requires a certain amount of time to set up. These tasks include, for example, selecting your audio drivers and specifying the location of your VST plug-ins. In addition, you will
find that REAPER has many more pages of preferences settings – and many more options within those pages – than does SONAR. Don't be intimidated by this. Part of the REAPER design
philosophy is that wherever possible individual users should be able to customize program behavior if they wish to suit the way they want it to work. We'll get to many of these later, but
for the most part you'll most probably find that you can work perfectly well just leaving many preferences options at their default settings.

Task/Activity
The Install Process

In SONAR you did this ...
Run the setup file, either downloaded or
from DVD

In REAPER you do this ...
Download the latest version from https://www.reaper.fm/download.php (updates with bug fixes,
performance enhancements and new features are usually released every month or so).
You'll notice straightaway that REAPER installs quickly (a couple of minutes at most) and leaves a small
footprint.
Most of the elements listed in the Choose Components screen are self-explanatory. Check the Additional
Functionality options for such features as x64 VST Bridging, Control Surface Support, CD
Ripping/Burning, and Rewire. By default, most of these options are enabled.
You should also install ReaRoute ASIO drivers if you want to run REAPER linked to another program such
as SONAR.

Setting up Audio

You are prompted during the install
process.

Options → Preferences → Audio

After this:

Note the following:

Edit → Preferences → Audio → Devices

Options → Preferences → Audio → Device (or click once on right end of main menu bar)
REAPER's Solo in Front is equivalent to SONAR's Dim Solo
REAPER's Channel Name Aliasing is similar to SONAR's Friendly Names
REAPER prefers ASIO drivers.

Setting up MIDI

Edit → Preferences → MIDI → Devices

Options → Preferences → Audio → MIDI Devices
Double-click on any input or output device to configure settings.

Portable Install to hard drive
or USB drive

SONAR does not appear to support this.

Tick the Portable Install box during the install process.
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Task/Activity
Setting up Control Devices

In SONAR you did this ...
Edit → Preferences → MIDI → Control
Surfaces

In REAPER you do this ...
Use Options → Preferences → Control/OSC/Web for any device operating
Behringer BCF2000
HUI (partial)
Frontier Alphatrack
Mackie Control Extender
Frontier Tranzport
Mackie Control Universal

in any of these modes:
OSC (open sound control)
Presonus Faderport
YAMAHA 01X

There is also a Web browser interface option which lets you set up your mobile phone or tablet as a
control device.
For BCR2000 users, please note that a plug-in has been developed by REAPER forum member ajaym
that allows you to install the BCR2000 as a control surface. See REAPER web site.
For other devices , use Options → MIDI Devices. Configure device to Input (Control Only) and output
disabled.
System Info and File Locations SONAR stores much of its system
information in the Windows Registry.
You can use Edit → Preferences → File →
Folder Locations and Edit → Preferences →
File → Audio Data to specify the locations
of various file types.

Setting up VST and DX Plug-ins Edit → Preferences → File → VST Settings

REAPER does not use the Windows Registry. Most system information (FX Chains, Color Themes, Key
Maps, Menu Sets, JS Effects etc) are stored in the App Data directory, accessed from REAPER's Options
→ Show REAPER Resource Path … command.
Native ReaPlugs (ReaEQ, ReaComp, etc.) are stored within the REAPER program directory.
Global default location for media files is specified under Options → Preferences ->Audio → Recording.
This can be overwritten for any project when saving the project file by selecting the Create Subdirectory
and Move All Media Items to Project Directory options. You can also set this in the File → Project
Settings dialog box.
Options → Preferences → Plug-ins → VST
Options → Preferences → Plug-ins → Rewire/DX
Some DX plug-ins may not be automatically be recognized by REAPER. If this is the case, go to your
\Application Data\REAPER folder and edit the text file reaper-dxplugins.ini. You will need to change the
line Load=0 to Load=1 for those plug-ns that have not been recognized.

REAPER Keyboard Shortcuts, Tips and Techniques:
File → Project Settings
Alt + Enter
Options → Preferences
Ctrl + P
Navigate Preferences pages either with mouse or keyboard (press first letter off page name (e.g. type C to jump to Control Surfaces page).
Use Find text box (bottom left corner of Preferences window) to search – see image on right.
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3. First Look
A first look at the REAPER screen reveals very little  A menu across the top.
 Below that, a toolbar (left) and a ruler (right).
 Below these, a dark track panel area (left) and a lighter arrange area
(right).
 Below this, a transport bar.
 Below this, a mixer area.
In the illustration (left) we have added a single track (by double-clicking in the
track panel area).
The track panel contains a number of track controls. These are fairly standard
and broadly similar to Sonar – volume, pan, mute, solo, etc. You can hover your
mouse over any control for a tooltip.
You can use your mouse to tweak this layout as you wish. In each case, hover it
on the border of whatever you want to change, so that the mouse cursor
changes to a double-headed arrow, then click and drag as required:
 Between the track panel and arrange areas, drag left/right to assign
more room to the arrange or track panel area. Dragging left might cause
some track controls to be hidden. These can be restored by dragging
back.
 Over the lower boundary of a track: drag up/down to make the track’s
panel smaller or bigger. Dragging up may cause some track controls to
be hidden. These can be restored by dragging back.
 Between the transport bar and the mixer: drag up/down to make the
mixer area larger/smaller.
“Out of the box”, REAPER does not include a track inspector, something that for
many users plays an important part in Sonar.
However, it’s not all bad news. One core aspect of REAPER is the extent to which
it can be customized to meet your personal requirements. This is not the place or time to go into this in detail, but keep in mind that when you become a little more familiar with REAPER
there are options which can give you a track inspector:
 Create your own basic track inspector using a combination of screensets and docking. Once you know how to use these features, it’s neither difficult nor time consuming, or
 Use scripting to create a more sophisticated track inspector. REAPER’s user base makes available a whole library of scripts that you can download and install. This includes one
that will give you a track inspector.
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4. Recording Essentials
Section Overview
For the most part SONAR and REAPER handle creating tracks and recording in ways that are quite similar. One of the biggest and most important differences can be found in how the two
products handle MIDI recording. SONAR uses different track types for audio and MIDI, as well as having Instrument tracks, whereas REAPER uses one common track type for both audio
and MIDI. In fact, with REAPER you can record both audio and MIDI items on the same track if you wish. REAPER's basic track controls do not by default include the many controls that are
included in SONAR's MIDI tracks. You can add these via the command Show Track MIDI Controls in the main Track menu or the track context menu. Another major difference is that
REAPER does not include a separate Synth Rack View. REAPER does, however, include the following features:


A Virtual Keyboard that you can use for MIDI input. Using either your mouse or your PC keyboard.



It allows you to use as many different synths (and/or different instances of the same synth) as you wish within a single track, either in serial or in parallel.



You can play back MIDI events from different channels thru different synths within a single track.

These features go beyond the scope of this “quick start” guide: for more information, consult the REAPER User Guide and/or REAPER Power!

Task/Activity

In SONAR you did this ...

In REAPER you do this ...

Create Audio Track(s)

Insert → Audio Track
Insert → Track Template ...
Insert → Multiple Tracks

Track → Insert or Double-click in track panel area.
Track → Insert Track from Template
Insert → Multiple Tracks

Create MIDI Tracks(s)

Insert → MIDI Track
Insert → Track from Track Template
Insert → Soft Synths

Track → Insert New Track then Track → Show Track MIDI Controls
Track → Insert Track from Template or Insert → Track from Template
Insert → Virtual Instrument on New Track

Note: REAPER makes no distinction between a MIDI track and audio track. You can have both media types on the same track if you wish.
Arm/Disarm Audio Track For
Recording

Use the track's Record On/Off toggle button.

Select Option to Record Track Audio Available for output of soft synth tarcks.
Output (rather than input)

Use the Record Arm/Disarm Toggle button in the track control panel. Default setting is to
record track input.
Available for any track. Right click on track Record Arm button, follow menu to Record: Output,
then select your preference from sub-menu..

Assign Track Inputs

Use Inputs drop down list in track controls or
track inspector.

Right click on track Record Arm button, follow menu to Mono Input, Stereo Input, or MIDI
input.

Assign Track Outputs

Use Outputs drop down list in track controls or
track inspector. By default, all audio track
output automatically goes to the Master.

Click on track I/O button to open the track's routing window. By default, output of all top level
tracks goes directly to the Master. Output of all child tracks (contained within folders) goes to
the folder and from there to the Master.
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Task/Activity

In SONAR you did this ...

In REAPER you do this ...

Enable/Disable Input Monitor

Use the track's Input Echo button on track
inspector.

Use the track's Record Monitoring button, or right click on Record Arm button, follow menu to
either Monitor Input or Monitor Input (Tape Auto Style). Optionally, you may also enable
Monitor Track Media When Recording.

Input Quantize (MIDI)

Use the track's Input Quantize button on track
inspector.

Right click on track Record Arm button, then choose Track Recording Settings.

Select Record Mode Normal

Right-click on Record button on Transport Bar
to open Record Preferences. Make sure Auto
Punch is not enabled.

Options → Record Mode: Normal

Select Record Mode Auto Punch

Right-click on Record button on Transport Bar
to open Record Preferences. Make sure Auto
Punch is enabled.

Options → Record Mode Time Selection Autopunch or

Enable/Disable Multiple Takes

Right-click on Record button on Transport Bar
to open Record Preferences. Select Sound on
Sound or Overwrite.

REAPER's default behavior is similar to SONAR's Sound on Sound mode. Ctrl +L toggles display
of multiple takes in lanes. To use its equivalent of Overwrite mode, choose (from the Options
menu) Trim Existing Items Behind New Recording. REAPER also supports Free Item Positioning
Mode (on track context menu).

Show/Hide Virtual MIDI Keyboard

SONAR does not appear to support this.

View → Virtual MIDI Keyboard.

Show/Use Metronome

Edit → Preferences → Project → Metronome

Options → Metronome and Pre-Roll Settings, or
Insert → Click Source (on selected existing empty track)

Start Recording

Use Record button on Transport Bar

Click Record button on Transport Bar (or press Control + R).

Stop Recording

Use Stop button on Transport Bar.

Click Stop button on Transport Bar (or press Space).

Other Transport Bar Functions

Core functions (Play, Stop, Pause, etc.) are similar. See SONAR and REAPER documentation for other features and differences.

Options → Record Mode Autopunch Selected Items

REAPER Keyboard Shortcuts, Tips and Techniques:
Insert → New Track
Ctrl + T
Options → Preferences
Ctrl + P
Start Recording
Ctrl + R
Stop Recording
Spacebar
See also Options → Preferences → Audio → Recording

Show Multiple Takes in Lanes (toggle)
View → Big Clock (toggle)
View → Docker (toggle)
for various options and settings.
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5. Tracks and Track Management Essentials
Section Overview
In many respects, REAPER's and SONAR's track management features are quite similar, and are available in the Arrange (Track) view and Mixer (Console) view . However, there are some
important differences, as explained in the table below. Not every option or feature is listed, only the most common ones. One key area of difference is in routing. REAPER makes no predistinction between tracks and busses. Any track can be used as a bus and any bus can be a track.

Task/Activity

In SONAR you did this ...

In REAPER you do this ...

Input Gain for Track or Bus

Use gain fader in the track inspector.

No real input trim. Use Volume (Pre FX) envelope or a JS Volume plug-in in FX chain.

Adjust Volume

Click and drag track volume fader.

Click and drag volume fader. Use Ctrl key for fine tuning adjustments or Scroll mousewheel
over volume fader (this can be disabled in Preferences, Editing Behavior, Mouse) or Right
click over volume fader and enter a value.

Adjust Pan

Click and drag track pan fader.

Click and drag pan fader. Use Ctrl key for fine tuning adjustments or Scroll mousewheel over
pan fader (this can be disabled in Preferences, Editing Behavior, Mouse) or Right click over
pan fader to over-write default pan law.

Mute Track (toggle)

Click on track mute button.

Click on track mute button, or right click for various mute options.

Solo Track (toggle)

Click on track solo button.

Click on track solo button, or right click for various solo options.

Dim Solo/Solo in Front

Use Dim Solo button on mix module.

Options → Solo in Front. Use Audio, Mute/Solo page of Options → Preferences to configure.

Freeze/Unfreeze Track

Click on Freeze button.

Right click on track panel, choose Render/freeze tracks.

Set Automation Mode

Click on Read or Write button.

Right-click on Envelope button, choose one of Trim/Read, Read, Write, Latch or Touch.

Add FX to Track

Right click over track FX bin.

Click on FX button.

Save Track(s) as Track Template

Right-click, then Save as Track Template.

Select track(s), right-click, then Save Tracks as Track Template.

Group Parameters

Right click over parameter, then select a group or
choose Group Manager.

Right click on track panel and choose Track Grouping Parameters (or use Grouping Matrix
View).

Hide/Show Track

Right click and choose Hide Track, or Press M to
display track manager

View → Track Manager (or Control + Shift + M). Toggle track visibility on/off in TCP column.

Archive Track

Use track's Archive button.

REAPER does not support this feature. However, by default tracks that are muted and
hidden will use no resources.
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Task/Activity

In SONAR you did this ...

In REAPER you do this ...

Change Track Order

Drag and drop - be careful!

Drag and drop (on track number) – be careful!

Use Console/Mixer View

Views → Console.

View → Mixer (or Control + M). Use right click menu (over background area) to customize.

Create a Send to a Bus

Create the bus (Insert → Stereo Bus), then rightclick in track panel, Insert Send then choose bus.

Create an empty track to be used as a bus, then …. Drag and drop from the track I/O
button to the bus I/O button, or Click on the track I/O button and add send, or Use the
Routing Matrix View.

Create a Send to any other Track

Limited functionality using aux tracks and patch
points.

Drag and drop from the source track I/O button to the destination track I/O button, or
Click on the track I/O button and add send, or Use the Routing Matrix View.

Create Submixes

Create a bus. In the track panel for each track to Several methods are available. The easiest is to insert a new empty track above the first
be included in the submix, select the bus from the track in the group. Click on that track’s track folder icon (located below the track number)
output drop down list.
once to make it a folder. Click twice on the track folder icon for the last track in the group to
make it the last track in the folder.. Note that REAPER’s folders are different from Sonar’s.
In REAPER a folder is a submix.

Lock Track Controls (toggle)

SONAR does not appear to support this.

Right click over track number, choose Lock Track Controls.

Show Bus/Track Peak Markers

Use Meter Options drop-down list on toolbar.

REAPER does not support this feature.

Bus Waveform Preview (toggle)

Use the bus Waveform Preview button.

REAPER does not support this feature.

(In REAPER a bus is a normal track
receives sends from other tracks)

Mouse and Keyboard Shortcuts, Tips and Techniques:
REAPER has numerous shortcuts and actions that can be used to control track display and visibility. Listed here are those most commonly used:

Track Display and Navigation Shortcuts
Drag between tracks with mouse

Adjust individual track height

W or Home

Go to start of project

PageUp

Increase all track heights (zoom in vertical)

End

Go to end of project

PageDown

Decrease all track heights (zoom out vertical)

Ctrl + Alt + Up

Go to previous track

` key

Toggle all tracks normal/minimized

Ctrl + Alt + Down

Go to next track

~ key

Toggle maximize track

Toggle View → Mixer

Ctrl + M

Double-click vertical scroll bar

Toggle minimize/normal/maximize

Ctrl + Alt + M

Show/Hide Master in Arrange View

+

Zoom out horizontal

Mousewheel

Zoom in/out horizontal

-

Zoom out horizontal

Ctrl + Mousewheel

Zoom in/out vertical

Ctrl + PageDown

Zoom to project length
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6. Media Item Management Basics
Section Overview
REAPER and SONAR superficially have quite similar approaches to managing and editing media items: however, the deeper you dig, the greater the differences. Some points to note:


Fade-ins, fade-outs and slip edits are handled similarly by both programs.



Basic techniques for copying, moving and deleting items are quite similar. REAPER also has many nudge options, including a Nudge window (right-click, Nudge Items).

Task/Activity

In SONAR you did this ...

In REAPER you do this ...

Insert Media Item

File → Import.

Insert → Media File or press Insert or use Media Explorer (View → Media Explorer).

Modify Clip/Item Properties

Right click for context menu.

Right-click, choose Item Properties (or press F2).

Display Media Item Icons

FX button will be displayed if FX have been
added to the media item.

Options → Preferences (or Control + P), then Appearance, Media. Enable/disable as you
wish.

Other icons used include mute clip and lock
clip.

Open MIDI Item with MIDI Editor
(Piano Roll View)

Double-click on item.

Double-click on item. At a glance, the two MIDI Editors appear quite similar, but there are
important differences. For example, SONAR makes extensive use of tools, REAPER of actions.
Right-click on item, then Open Items in Editor → Open Items with editor as previously
specified in Options → Preferences then External Editors.

Open Audio Items with External Audio
Editor
Snap to Grid (settings and enable)

Use Snap to Grid button on toolbar.

Options → Snap/Grid → Snap/Grid Settings, or use Grid button on main toolbar.

Ripple Editing

Use Track View Options menu.

Options → Ripple edit per track or Options → Ripple edit all tracks (toggle).

Add FX to Clip/Media Item

Right-click, Insert Effect

Click on item FX button, or Right-click, Take → Show FX Chain for Active Take, or Shift + E

Toggle Display of Takes in Lanes

Use track's Track Lanes Buttons

Options → Show All Takes in Lanes or Ctrl+ L

Use Navigator View

Views → Navigator.

View → Navigator (ot Control + Alt + V).

Adjust Take Volume

Closest equivalent is the track Trim Fader.

Click and drag down from top edge of of item to lower: Shift click and drag up from top edge
of item to increase.
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Task/Activity

In SONAR you did this ...

In REAPER you do this ...

Show Clip/Media Item Envelopes

Set Edit Filter to Cledite ips. Choose Clip
Automation from drop-down menu.

Right click, Take, then Take Volume Envelope, or Take Pan Envelope, or Take Mute Envelope.

Split Clip/Media Item

Select item, position cursor, press S

Select item, position cursor, press S.

Create Loop From Item

Right-click, View → Loop Construction

By default REAPER's media items are loop enabled. To toggle this status off/on, right click,
Item Settings → Loop Item Source.

Mute Part of Media Item

Use Mute smart tool.

Create a custom action to split and mute, or use track or take Mute envelope.

Mute Clip/Media Item (toggle)

Right-click, Clip Mute/Unmute

Right-click, Item Settings → Mute or Use item mute button.

Lock Clip/Media Item (toggle)

Right-click, Clip Lock

Right-click, Item Settings → Lock Item or Use item lock button.

Render Clip/Media Item

Right-click, Bounce to Clip(s)

Right-click then select one of the Apply Track FX or Render Items options.

Group Selected Clips/Media Items

Right-click on any selected item, Create
selection group from selected clips.

Right click on any selected item, Group → Group Items.

Manage Grouped Media Items Status

SONAR has no real equivalent.

Select items, right click Group, then choose from menu.

Nudge Items

Process → Nudge from main menu, or use
keyboard shortcuts.

Use keyboard shortcuts (see below), or right-click then choose Nudge Items … for Nudge
dialog box.

Keyboard Shortcuts, Tips and Techniques:
View/Edit Item Properties

F2

Split Item(s) at Cursor

S

View Source Media Properties

Ctrl + F2

Split Item(s) at Time Selection

Shift + S

Cut Selected Area of Item

Ctrl + Delete

Nudge item(s) up/left/right/down

Num Lock 2/4/6/8

Copy Selected Area of Items

Ctrl + Shift + C

Nudge contents of item left/right

Num Lock 1/3

Copy Loop of Selected Area of Items

Ctrl + Alt + L

Grow/Shrink left edge of item

Ctrl + Num Lock 4/6

Time stretch (warp) item

Alt click and drag from start or end

Grow/Shrink right edge of item

Alt + Nim Lock 6/4

Show FX Chain for Active Take

Shift + E

Move cursor to left/right edge of item

Ctrl + [ / Ctrl + ]
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7. Managing and Editing MIDI Items
The way in which MIDI items are managed and edited in REAPER is very significantly different from SONAR. This really is an area where you may need to take some time to adjust to the
differences. The following table contains some useful pointers.

Task/Activity

In SONAR you did this ...

In REAPER you do this ...
Record, or select track and make time selection, then Insert → New MIDI Item. Doubleclick on this to open MIDI Editor.

Create MIDI Items

Record, or use Piano Roll View.

Loop Enable MIDI Clip/Item

Select clip. Ctrl + L toggles looping on and off, By default, all media items (including MIDI) are loop enabled. This can be changed for
or right-click over clip and choose Groove – Clip individual items (or selections of items) using the Item Settings → Loop Item Source toggle
Looping from menu.
command from the right-click context menu.
To change the default behavior for new items, disable Loop source for new MIDI items in
Project → Defaults.

Assign MIDI Items to a Synth.

Use a separate Instrument Track.

Insert Synth in track FX chain.

Assign Different Channels from the
Same MIDI Item to Different Synths.

SONAR does not appear to support this.

Use a separate send (track i/o button) for each channel that requires a separate
instrument.

Edit MIDI Items or Clips

Use in-line Piano Roll or right-click on clip and
Double click to open in standard MIDI Editor or right-click and choose Open Items in Editor
choose View, then Piano Roll View, Event List or → Open in Inline Editor. Use View → Mode: event list in the standard MIDI editor for CCs
Staff View.
and other events. Use Piano roll, Named notes or Musical notation view to edit nptes.

Manage Clips/Items in Sequence on a
Single Track

All MIDI notes on the same track are essentially
treated as a single clip (item). For example, all
are accessible when you open the Piano Roll or
Event List View. You may also Bounce to Clip to
join a selection of shorter items.

Each item is separate and can be opened in its own MIDI Editor Window or together with
other MIDI items, depending on your MIDI Editor preferences settings. By default, the
dimensions of that MIDI Editor window will be constrained by the dimensions of the MIDI
item. This issue simply does not arise in SONAR. If in REAPER you think you are likely to
need to add notes (or other events) before an item, after an item, or between existing
items then it would be wise to prepare for this before opening the MIDI Editor.
To do this, you should disable the Loop Item Source option (right-click, then Item Settings,
then disable the Loop Item Source toggle option), then stretch its edges outwards (slip edit
style), or Join the items together, by selecting them, then right clicking and choose Glue
Items from the context menu. See screen shots below table. This enables you to open
them all together in the MIDI Editor and add notes in between the original items.
You can also drag the edge of a loop disabled item in the MIDI Editor in order to extend it.
Also, if within the MIDI Editor you insert a note that goes beyond the end of the item then
that item will automatically be extended.
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Task/Activity
Read Cakewalk.ins or Other
Instrument Definition File for
Bank/Patch Names.

In SONAR you did this ...

In REAPER you do this ...

Edit → Preferences → MIDI→ Instruments ,
then click on Define, then Import. Select file,
click on Open.

Right-click on track name or number and choose MIDI Track Controls then Show MIDI
Track Control Panel. This opens ReaControl MIDI in the track FX chain. Display this, enable
Bank/Program Select, click on Load File, select file, then click on Open.
ReaControl MIDI can also be used with individual MIDI items, via their FX chains.

Use Various MIDI Track Controls

Use widgets in track control panel.

Use the various ReaControl MIDI controls. Also, many JS MIDI plug-ins are available. Type
“MIDI” in the Add FX dialog filter for a list.

Handling System Exclusive Data

Use Sysx View.

Drag and drop a .syx file directly on to the track to load directly into a track, or Use
ReaControl MIDI: click on Sysex Edit button and paste data in. F0 and F7 are added
automatically at the start and end respectively.

Export MIDI Data as MIDI File

File → Save As. For individual clips, File →
Export→ MIDI Groove Clip

File → Export Project MIDI. For individual items, open in MIDI editor, then File → Export to
new MIDI File.

Add Lyrics to Project

Views → Lyrics.

REAPER has no separate lyrics view as such, but the MIDI Editor’s Musical Notation View
allows you to add lyrics to a music score.
Double-click on a MIDI item to open it in the MIDI Editor, then View → Mode: musical
notation. Right-click at required location, choose Lyrics… from context menu.

Joining MIDI Items in REAPER
Before … two separate discrete MIDI
items on a track.

After selecting both items and choosing
Glue Items from the context menu.
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8. Plug-in and FX Management
Section Overview
Most SONAR users who come to REAPER find that at first they miss being able to manage a track's plug-ins directly from a bin in the track control panel (although these can be accessed
directly in the Mixer view). However, you will soon discover that REAPER's FX Window includes an impressive selection of other features which should more than make up for this.

Task/Activity

In SONAR you did this ...

In REAPER you do this ...

Add FX to a Track

Right-click over FX bin, then follow menu.

Click Add button on track FX window. Double-click on required FX or drag and drop.

Change Order of Track FX

Drag and drop.

Drag and drop.

Delete FX from Track

Right-click on FX, choose Delete.

Select FX in track FX chain, press Delete.

Replace one FX with anoher

Right-click on FX in FX chain, choose Replace FX… from menu.

Bypass FX (toggle)

Use FX Bypass toggle in track FX bin.

Use FX Bypass toggle in track FX Chain window or FX window.

Rename and Reorganize Plugins

Utilities → Cakewalk Plug-In Manager.

View → FX Browser (or Shift + F).

Create FX Chain

Right-click in FX Rack, Save FX Rack as FX
Chain Preset.

Right-click on track FX chain then Save FX Chain or Save Selected FX as Chain.

Create Track Default FX Chain

Right-click on track FX chain then Save Chain as Default for New Tracks.

Add FX Chain to a Track

Right-click in FX Rack, Insert FX Chain Preset.

In FX Chain Window choose FX → Add FX Chain from top menu.

Rename Individual FX Instance

SONAR does not appear to support this.

Select the FX, then press F2 or right-click, then Rename FX Instance.

Adjust FX Wet/Dry Mix

SONAR does not appear to support this.

Use Wet/Dry rotary control next to bypass checkbox in FX window.

Use in Track Parallel FX Processing

SONAR does not appear to support this.

Click on pin connector (labeled 4 in 2 out or similar) to assign FX inputs and outputs to
specific channels. Use a JS mixer plug-in to mix different parallel FX streams.

Add Parameter Controls to Track
Control Panel and Mixer Control Panel

Up to four controls per track can be displayed
at any one time in Console View only.

Touch parameter control with mouse, then click on Param button in FX chain window.
Choose Show in Track Controls.

Manage Plug-in Preferences/Settings

Edit → Preferences → VST Settings.

Options → Preferences (or Control + P) then Plug-ins, VST, and ReWire/DX pages.
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9. Automation
Section Overview
Both SONAR and REAPER use envelopes to automate track and FX parameter data, but their respective feature sets are significantly different. This table should help steer you thru these.
Probably the most significant difference between the two is that SONAR does not appear to support Parameter Modulation.

Task/Activity

In SONAR you did this ...

In REAPER you do this ...

Create Track Control Envelope

Enable Write button in Track Inspector. Play
song, adjust control (e.g. Pan)

Click on track Env button to display envelopes window for track, then check boxes for
envelopes required, or use keyboard shortcuts (V for Volume, P for Pan).

Create Track FX Parameter Envelope

Right click on FX, use Write Enable Parameters Click on track Env button to display envelopes window for track, then check boxes for FX
to select parameters (e.g. Compressor Ratio). parameter for envelopes required, or In FX window, touch parameter with mouse then click
Play song, adjusting parameter.
on Param button, then Show Track Envelope.

Create Clip/Media Item Control
Envelope

Right-click on clip, Envelopes → Create Clip
Envelope then select parameter.

Right-click on media item, then Take, then select Volume, Mute or Pan envelope from
submenu.

Create Clip/Media Item FX Parameter
Envelope

Open clip FX chain, then open the FX. Use
ACT.

Select item, press Shift + E to open Add FX to Item dialog. Select FX, then OK. In FX
window, click on parameter control, then Param button then choose Show media item take
envelope.

Setting Automation Mode

Use Track Controls – Read or Write only.

Right-click on Env button, select one of Trim/Read, Read, Write, Touch, or Latch.

Global Automation Override

SONAR does not appear to support this.

Right-click Global Automation Override button on Transport Bar.

Add/Manage Envelope Points

Use mouse.

Options → Preferences → Editing Behavior → Envelopes sets mouse behavior (click, shiftclick, double-click, etc.) for adding, editing and resetting points, adjusting segments, etc.

Curve Shape and Other Options

Right-click on envelope.

Right-click on envelope.

Show Envelope in Separate Lane

SONAR does not appear to support this.

Right-click on envelope, choose Show Envelope in Lane (toggle).

Draw Envelope Curves with Mouse

Select Draw Freehand tool, click and drag.

Depending on preferences, Ctrl-click and drag.

Automation Bypass Mode (toggle).

Disable Read button in Track Inspector.

Right-click on envelope, then Bypass Envelope.

Parameter Modulation

SONAR does not appear to support this.

Parameter Modulation is a very big topic. To cover it in detail would go beyond the scope
of this document. In short,it lets you use any audio stream or FX parameter from any track
to control the behavior of any FX parameter on itself or any other track.
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10.Loops, Markers and Regions
Section Overview
Both SONAR and REAPER use loops and markers to help you manage your projects. With the addition of the SWS Extensions, REAPER offers you several extra features. The information in
this table assumes that the SWS Extensions have been installed. REAPER also uses regions, something that SONAR does not recognize.

Task/Activity

In SONAR you did this ...

In REAPER you do this ...

Create Loop Selection

Click and drag along timeline, then Shift + L.. Click and drag along timeline.

Create Time Selection

Click and drag along timeline.

Click and drag in background area in Arrange View.

Link Loop Points to Time Selection

SONAR does not use this concept.

Options → Loop Points Linked to Time Selection (toggle).

Create Marker

Right-click on timeline, then Insert → Marker
or (on the fly) press F11

Insert → Marker or (on the fly) press M or Shift+M.

Display Marker View

Views → Markers

View → Region/Marker Manager (or Control + Shift + Alt + R).

Reorder/Renumber Markers

SONAR does this automatically.

Right-click in Region/Marker Manager window, then Renumber in Timeline Order.

Go to Marker

Use Transport Bar or Markers window.

Type number or use Region/Marker Manager window.

Delete Marker

Select in Markers window, press Delete.

Alt click on marker in timeline, or right-click and choose Remove Marker.

Create Smart (Command) Markers

SONAR does not appear to support this.

Begin marker name with ! Followed by command ID or IDs.

Export/Import Markers between
projects

SONAR does not appear to support this.

To export to .CSV file, right-click in Region/Marker Manager window, then Export
Regions/Markers …
To import, choose Import Markers/Regions (merge) or Import Markers/Regions (replace)
from same menu.

Create a Region

SONAR does not appear to support REAPER
type regions.

Define time selection, then either right-click on timeline, Create Region from Selection or
press Shift+R.

Move/Copy Region

SONAR does not appear to support REAPER
type regions.

Move: Click and drag along timeline.
Copy: Ctrl click and drag along timeline.
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11.Project Rendering and Related Topics
Section Overview
With both SONAR and REAPER you can mix down and render your projects for export, for example, as internet ready MP3 or CD ready WAV files, or for export to other programs. The
topics listed here fall loosely into this category. There are some interesting differences between the two feature sets.

Task/Activity

In SONAR you did this ...

In REAPER you do this ...

Export as OMF File

File → Export → OMF

REAPER does not support this feature.

Export as EDL or EDL Text File

SONAR does not appear to support this.

File → Save Project As (or Control + Alt + S), then select file type.

Export Mix as Stereo MP3 File

File → Export → Audio.

File → Render (or Control + Alt + R). Select Stereo from Channels drop down list and MP3
as output format. Select Render Master Mix.

SONAR also includes Pyro Web Publisher.
Export Mix as Stereo 16 bit WAV File (for File → Export → Audio.
audio CD)
SONAR also includes Pyro CD Burner.

File → Render. Select Stereo from Channels drop down list and WAV as output format.
Select Render Master Mix. Select Bit Depth 16, Sample rate 44100.

Export Individual Tracks as Separate
Files

Various options and permutations available
from Source Category drop-down list.

Include with your settings and specifications Render Stems (Selected Tracks).

Export in Multichannel Format

Requires Multichannel Format to have been
specified in Surround tab of Project Options.
Choose Multichannel from Channel Format
drop-down list.

Along with your other settings, select the required number of Channels and if required
enable the option Render Multichannel Tracks to Multichannel Files.

Import Audio from CD

File → Import → Audio CD.

Use the Media Explorer View. Drag and drop to arrange view.

Export Mix to Audio CD

After preparing projects to required format,
Utilities → Burn Audio CD.

After preparing project to required format, File → Render. Amongst other options, select
Output Format Audio CD Image. See User Guide for details.

Batch Render Files

SONAR does not appear to support this.

Prepare individual files in File → Render dialog box, clicking each time on Add to Render
Queue. Then File → Open Render Queue, with Render All or Render Selected.
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12.Customization
Section Overview
Understanding REAPER's customization lies at the very heart of really getting to grips with the program. Now read on ..

Task/Activity

In SONAR you did this ...

In REAPER you do this ...

Customization Overview

Edit → Preferences → Customization, then
select required category.

No “one stop shop.” Different customizations are available thru various menus.

Create Custom Actions

Some ability to bind keys to commands thru
Edit → Preferences → Keyboard Shortcuts.
Cannot create custom actions or macros.

Use Actions → Show Actions List to access actions editor. Any command can be assigned a
keyboard shortcut. Many hundreds of additional actions that can be assigned to keyboard
shortcuts, menus, toolbars, or control devices.
Any number of actions can be chained together to create custom macros, also assignable
to keyboard shortcuts, menus, toolbars, or control devices.
Also supports scripting with EEL, Lua and (if you insist) Python.

Custom Menus

Use Options → Customize Menus/Toolbars to customize menus and/or toolbars.

Cannot create your own menus.

You can rearrange REAPER's menus, including hiding unwanted commands.
Custom Toolbars

Cannot create your own toolbars.

Custom Colors and Skins

SONAR supports custom color schemes but is Actions → Show action list, then select and run the action Theme Development: show
not skinnable.
theme tweak/configuration window.

You can also add REAPER actions and your own custom actions to REAPER menus and
toolbars.

You can also create your own themes (using WALTER), or select any theme from the
REAPER stash.
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13.Miscellaneous: What Else Is Similar, What's Different and What's Missing?
Section Overview
This section summarizes in overview those areas where SONAR and REAPER are most significantly different. Also included here are some features that are present in one or other of these
DAWs but not the other.

Task/Activity

In SONAR you did this ...

In REAPER you do this ...

Assign Parameter Controls to Control
Surface

Use ACT.

REAPER handles this very differently, via Param button in FX window and Actions list editor.

Create/Use Audio/MIDI Matrix

Use Matrix View.

REAPER has no equivalent of this.

Edit Notation or Lyrics

Use Staff View or Lyrics View.

Double-click on item to open it in MIDI Editor. Choose View → Mode: musical notation.

Stretch and fit items to tempo, etc.

Use Audio Snap.

The closest equivalent to this in REAPER is Dynamic Splitting: right-click on media item, then
Item Processing → Dynamic Split Items.

Automatically correct vocal pitch

Use Melodyne.

The closest equivalent in REAPER is the Cockos VST plug-in ReaTune.

Surround panning

Use the Surround Panner.

Use the Cockos VST plug-in ReaSurround.

Automatically color tracks according
to the track name

SONAR does not appear to support this.

Extensions → Auto Color/icon/layout (requires SWS extensions).

Create and manage mixer snapshots
on a per project basis.

SONAR does not appear to support this.

Extensions → Snapshots (requires SWS extensions). Snapshots allow many different mixer,
track, FX, etc. settings (and different permutations of these) to be saved and recalled within a
single project file, and even to be copied between project files.

Create and manage screen sets

User Screensets toolbar module.

View → Screensets/Layouts (or Control + E). Screen sets allow different windows and track
layouts to be saved and instantly recalled. This includes the use of docking in Windows
screensets.

Monitor and manage CPU, disk and
RAM performance

SONAR displays only limited information on
its CPU and Disk meters.

View → Performance Meter for comprehensive performance management. Double-click on any
track name in the Performance Meter Window to open FX window for that track.

Create and manage global
database(s) of clips, media items,
audio files, automation items, etc.

SONAR does not appear to support this.

View → Media Explorer (or Control + Alt + X).
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14.REAPER Main Menu Command Keyboard Shortcut Summary Tables

(Note: not all commands have default keyboard shortcuts)

File Management (File Menu)

View Toggle Commands (View Menu)

Insert Commands (Insert Menu)

New project
Ctrl + N
Open project
Ctrl + O
Save project
Ctrl + S
Save project as …
Ctrl + Alt + S
Save new version of project
Ctrl + Alt + Shift + S
New project tab
Ctrl + Alt + N
Close project
Ctrl + F4
Project settings …
Alt + Enter
Render
Ctrl + Alt + R
Save live output to disk (bounc)
Ctrl + Alt + B
Batch file/item converter
Ctrl + Shift + F
Quit
Ctl + Q

Docker
Mixer
Master Track
Big Clock
Dynamic Split
Fx Browser
Grouping Matrix
Media Item Properties
Media Explorer
Navigator
Nudge/Set Items
Performance Meter
Project Media/FX Bay
Region/Marker Manager
Routing Matrix
Screensets/Layout
Tempo Envelope
Toolbar Docker
Transient Detection Settings
Track Manager
Transport
Undo History
Video Window
Virtual MIDI Keyboard
Show/hide all floating windows
Fullscreen

Media file …
Insert
Marker
M
Marker (prompt for name)
Shift + M
Region (from time selection)
Shift + R
Tempo/time signature change marker
Shift + C
Measure from tome selction
(detect tempo)
Alt + Shift + C

Edit Commands (Edit Menu)
Undo
Ctrl + Z
Redo
Ctrl + Shift + Z
Select all items/tracks/
envelope points depending on focus
Ctrl + A
Copy items/tracks/envelope points
within time selection if any
Ctrl + Shift + C
Copy items/tracks/envelope points
ignoring time selection
Ctrl + C
Cut items/tracks/envelope points
within time selection if any
Ctrl + Shift + X
Cut items/tracks/envelope points
ignoring time selection
Ctrl + X
Paste
Ctrl + V

Options Commands (Options Menu)
Auto crossfade media items when editing
Alt + X
Show all takes in lanes when room
Ctrl+ L
Item grouping enabled
Alt + Shift + G
Enable snapping
Alt + S

Enable Grid
Snap/Grid Settings ...
Locking enabled
Locking settings ...
Preferences

Alt + D
Ctrl + M
Ctrl + Alt + M
Alt + C
D
Shift F
Ctrl + Alt + G
F2
Ctrl + Alt + X
Ctrl + Alt + V
N
Ctrl + Alt + P
Ctrl + B
Ctrl + Alt + Shift + R
Alt + R
Ctrl + E
Alt + T
F
Ctrl + Alt + Shift + T
Ctrl + Shift _+ M
Ctrl + Alt + T
Ctrl + Alt + Z
Ctrl + Shift + Z
Alt + B
Ctrl + Alt + F
F11
Alt + G
Alt + L
L
Shift + L
Ctrl + P
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Track

Ctrl + T

Item Management (Item Menu)
Copy loop of selected area of item
Ctrl + Alt + L
Nudge/set items
Nudge
Split items at cursor
S
Split items at time selection
Shift + S
Item properties
F2
Source properties
Ctrl + F2
Group, Group items
G
Group, Remove items from group
U
Group, Select all items in group
Ctrl + G
Take, Next take
T
Take, Previous take
Shift + T
Take, Crop to active take
Alt + Shift + T
Take, Show FX chain for active take
Shift + E
Item processing, Normalize items
Ctrl + Shift + N
Item processing, Norm items, common gain Shift + N
Item processing, Dynamic split items
D
Stretch markers, add stretch marker
at cursor
Shift + W
Open items in edior
Ctrl + Alt + E
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